PHP 5.2 or 5.3 or 5.4 or 5.5 or 5.6

All our servers support (i.e. are capable of running) PHP 5.2 , PHP 5.3, PHP 5.4, PHP 5.5, and PHP 5.6 (with a few exceptions listed below). The default version is 5.4.x but you can follow the directions below to use  other PHP versions instead.

Exceptions: Newer VPS/Plesk installations have PHP 5.6 as the default, and do not support versions less tha PHP 5.5.

Before switching, be aware of backwards compatibility issues with scripts: Older PHP coding may not be compatible with newer versions of PHP.

Please keep in mind: Using PHP 5.4 will break any sites requiring Zend or ioncube that were encoded with PHP 5.2. We recommend you check with the application developers to see if they have a 5.4 version available.

How to Enable

Follow the directions below for the hosting plan you have.

Shared and Reseller

We currently have 5.4.35 (or higher) as a default PHP version on all servers. A handler for other PHP versions is added to our shared and reseller servers for those who wish to utilize it. In order to utilize this handler, you will need to add the following code to your .htaccess file to enable the respective PHP version:

# Use PHP 5.2
AddType application/x-httpd-php52 .php

Or the following for PHP 5.3:

# Use PHP 5.3
AddType application/x-httpd-php53 .php 

Or the following for PHP 5.5:

# Use PHP 5.5
AddHandler application/x-httpd-php55 .php
<IfModule mod_suphp.c>
suPHP_ConfigPath /opt/php55/lib

Or the following for PHP 5.6:

# Use PHP 5.6
AddHandler application/x-httpd-php56 .php
<IfModule mod_suphp.c>
suPHP_ConfigPath /opt/php56/lib

Linux Dedicated Servers

Do not use the Handler code listed above. Instead, you must email and request Apache be recompiled to use PHP 5.3.

VPS with cPanel

Do not use the Handler code listed above. Instead, you must email and request that PHP 5.3 be installed.

VPS with Plesk

Newer VPS/Plesk installations are setup with PHP 5.3, however some older installations may have previous versions. If your VPS requires an upgrade to 5.3 please email to request this.

Things to Keep in Mind

If you are using a custom php.ini file that references PHP modules that are not available with PHP 5.3, your site may not work. Either remove the custom php.ini file (which will cause the server to use the default php.ini file for PHP 5.3), or create a php.ini file that is compatible with PHP 5.3.

  • 3 Users Found This Useful
Was this answer helpful?

Related Articles


In the phpinfo.php page you can see the PHP version at the top of the file, and you can find the...

Register Globals and other php settings

To turn register globals off, you will need to create a php.ini file in the folder where the...

PHP setting limits

PHP has been configured to use the following settings on our shared and reseller servers:safe...

What version of PHP are you using?

All our servers support (i.e. are capable of running) both PHP 5.2 and PHP 5.3. The default...

Powered by WHMCompleteSolution